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ELEMENTS OF AN EXCEL DOCUMENT 
When you open Excel, a blank workbook is automatically opened. A workbook is a file with one 
or more sheets; each worksheet (sometimes called “spreadsheet) is a “page” in the workbook 
where you enter and work with your data. Each workbook starts with one sheet, but you can add 
more by clicking on the Insert Worksheet icon to the right of your last sheet’s tab (circled below). 
To change the name, double-click on the sheet’s tab and then type the new name. 
An Excel worksheet is made up of a series of columns (named with letters e.g. A, B, C…) and 
rows (named with numbers e.g. 1, 2, 3…) that define the cells – for example, “F27”, as below. To 
enter data (text or numbers), click in the appropriate cell and start typing. When you type, the data 
goes into the currently selected cell, called the active cell. All the data you enter in the active cell 
appears in the Formula bar. If you need to change the data, you can double-click on the cell to 
activate the cursor in the cell, or click in the Formula bar and make the change there.  

 
The Formula bar is not “docked” (connected) to the other toolbars, so you can move it around 
independently. To navigate more quickly in your worksheet, use the arrow keys on the keyboard 
to move left, right, up and down. In addition, you can use the following other keystrokes: 

• Return accepts your entry and moves the active cell down one; hold down the Shift key as 
well and you will move back up. 

• Tab accepts your entry and moves the active cell to the right. Again, hold down the Shift 
key as well as the Tab key and you will move to the left. 

The Esc key or red X in the Formula bar will abort your change. 

Active Cell 
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RESIZING AND HIDING COLUMNS AND ROWS 
You can change a column’s width by putting your cursor between the letter for that column and 
the next (between A and B at right). When you get the two-headed arrow, drag to the right or left 
as desired. 
Double-clicking on that same spot will “autofit” the 
column, making the column as wide as the largest 
piece of text/data in that column. 
The same technique works for rows; put your cursor 
between the two numbers until you see the two-headed arrow, and then drag or double-click. 
To hide a column or row, put your cursor on any cell in the column or row, go to the Format 
menu, then Column (or Row) and choose Hide. To unhide a column or row, select the columns 
or rows before and after the missing column or row, go to the Format menu, then Column (or 
Row) and choose Unhide. 
For exact height or width control, go to the Format menu, then Column (or Row) and choose 
Width… (or Height…). 

USING PANES TO CREATE SPREADSHEET HEADERS 
If your data set is large and it is difficult to see which values correspond to 
what heading, you can make the top rows and leftmost columns into headers 
that will stay put at the top and left as you scroll around the page. 

1. At the top of the vertical scroll bar, there is a thick bar. Move your 
cursor over this bar and it changes to two parallel lines with an arrow.  

2. Click and drag to divide the window vertically into panes. Adjust the 
split so that the first row (or two) is the only row in the top pane. 

3. To set a horizontal pane, use the similar thick bar at the lower right 
corner of the scroll bar and drag it to the left. 

4. To freeze the panes in place, go to the Window menu and choose 
Freeze Panes. 

Note, you don’t have to set them both; you can use just the vertical or just the horizontal. Once 
you freeze the panes, however, you need to unfreeze them to either adjust them or add another 
pane. 
To remove the pane(s), go to the Window menu and choose Unfreeze Pane. 
Once you have the column and row headings in place, you can scroll left to right and top to 
bottom and they will remain in place. This can be very useful to manipulate your data – see the 
Sorting Data section on page 13 for more information. 
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Excel’s guess to what 
the next cell should be. 

USING THE AUTOFILL COMMAND  
Excel has the feature that helps you automatically enter data. If you are entering a predictable 
series (e.g. 1, 2, 3…; days of the week; hours of the day) you can use the AutoFill command to 
automatically extend the sequence. You can also use this for formulas – set up the formula once, 
then use the AutoFill to propagate it to the other cells. 

USING AUTOFILL FOR SEQUENCES 
For Excel to know how to fill in the series, you usually need to provide two or three examples. In 
the case of months, weekdays, and hours, you only need to provide one example.  

1. Type in either the first element (e.g. January or any month) or the first two elements (e.g. 
1, 2) of a series.  

2. Select the cell(s) you just typed in.   
3. Move the cursor over the little block in the lower right corner of the active cell, and the 

cursor changes to a hairline plus sign (+), as opposed to the usual block plus sign.  
4. Click and hold on the fill handle and drag to the right (or down) to fill in the series. Note 

that Excel can only extend series by adding to the sequence (that is, the next month, 
adding the same number, etc.), not other kinds of math such as square, multiplication, etc. 

 
 
 

USING AUTOFILL FOR FORMULAS 
To use AutoFill with formulas, insert the formula and make sure it works (more about working 
with formulas later in this document!).  

1. Select the cell(s) with the formula and move the cursor over the little block in the lower 
right corner of the active cell, and the cursor changes to a hairline plus sign (+), as 
opposed to the usual block plus sign.  

2. Click and hold on the fill handle and drag to 
the right (or down) to fill in the other cells. 
Excel automatically adjusts the formula for 
the row it is now on (so, in the example at 
right, Captain Crunch’s total formula would 
read =SUM(D4:M4) and so on. 

A Note about using AutoFill with functions: If 
you want a constant reference (for example, each 
column should be divided by a certain cell’s data), 
add a dollar sign ($) in front that cell’s reference in the Formula bar.  For example, if  =D8*$P$8 
is in the Formula bar and you AutoFill from this cell, the next cell would read =D9*$P$8, 
changing the first cell, but keeping the second cell reference constant – otherwise, it would read 
=D9*P9. Another way to accomplish this would be to define the constant and then reference the 
constant, as seen in the Creating Weighted Averages section on page 7. 
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USING FORMULAS AND FUNCTIONS 
Formulas in Excel are useful to perform various mathematical, statistical, and logical operations.   
You can type in a formula (though you have to be sure it’s exactly right) or you can use Excel’s 
preset formulas called functions. Excel can perform simple tasks like a calculator; for example, if 
you typed in =5*6 then pushed Enter/Return on the keyboard, what would appear in the cell 
would be 30.  If you selected the cell again, though, you would see the formula =5*6. If you type 
in the formula, you must start with an equal sign, so Excel knows that the data in the cell is a 
formula. After the =, what comes next depends on what you’re trying to do.  If you were 
multiplying numbers (like in the above example), you would just type in the appropriate numbers 
and mathematical symbol (* for multiply). 
The power of Excel, however, is to do more complicated calculations, including calculations for 
the cell itself, no matter what the content (meaning, if the content of the cell changes from a 5 to 
a 8, for example), and more complex formulas (such as 
averages, sums, etc., beyond basic math). Just like a basic 
formula, you need to start with the equal sign.  After that, 
you would put the function name, then the range of cells 
inside parentheses, separated with a colon. For example: 
=SUM(B2:B5). 
Luckily, Excel has many preset functions, so you don’t have 
to remember exactly what to type in – just remember the 
name of the function. 

USING THE AUTOSUM COMMAND 
Since adding is used so frequently in Excel, there is an icon on the toolbar that will attempt to do 
it automatically. When you use the AutoSum command, Excel guesses what data you want to sum 
together (usually a block of cells next to the cell where the formula is).  
To use the AutoSum, go to the cell where you want the summation result to appear, click 
on the AutoSum icon in the Standard toolbar, and verify that Excel’s guess is correct. If it is 
not correct, select the cells you wish to add to the formula by clicking on the first cell and 
dragging to the last one. Then press Return on the keyboard. The sum of the data of the selected 
range of cells will appear in the cell with the formula. If any of the values in this range of cells are 
changed, the cell with the summation formula will automatically update to reflect the new sum. 
An example of a sum is displayed in the picture above this section. 
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INSERTING A FUNCTION 
Before anything, you need to make sure your cursor is in the cell in which you want the result. 
You can insert functions by either going to the Insert menu and choosing Function… or by 
clicking on arrow next to the AutoSum icon and selecting More Functions…. 
The Formula Builder part of the Formatting Palette become active, and a list of operations that 
Excel can perform are displayed. 
When you choose a function from the list 
(scroll to it or find it in the Search box), the 
bottom portion of the Formula Builder 
changes so you can select the cells you would 
like to involve in the formula. To select, use 
the mouse to click on the first cell and drag 
through the cells you would like to add. Note 
that for each function, this bottom portion 
will look different. 
If you’re not sure how to use a particular 
function, you can click the More help on this 
function below the function description and 
that will bring up Excel’s Help. 
Once the function is in the cell, you can copy 
and then paste it into another cell to do the 
same function for that different range of cells. 
You can also use the AutoFill command (click 
cell with the function, then drag to the right or 
down). The formula adjusts automatically for 
the new values.  
As mentioned before, if you want a constant reference (for example, each column should be 
divided by a certain cell’s data), add a dollar sign ($) in front that cell’s reference in the Formula 
bar.  For example, if  =D8*$P$8 is in the Formula bar and you AutoFill from this cell, the next 
cell would read =D9*$P$8, changing the first cell, but keeping the second cell reference constant 
– otherwise, it would read =D9*P9. Another way to accomplish this would be to define the 
constant and then reference the constant, as seen below in the Creating Weighted Averages section. 
There are so many different functions in Excel that it would be difficult to cover them all, but we 
will include a few below in addition to the AutoSum that was explained above on page 5. 
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Quick Reference: 
1. Enter weights 
2. Select cells and name weights 
3. Insert the sumproduct function 

a.  Array 1 = first student’s scores 
b.  Array 2 = Weights 

4. Click OK and AutoFill 

CREATING WEIGHTED AVERAGES EXERCISE 
Suppose the final exam is 50% of the grade, and the 
homework and midterm are 25% each. To make a weighted 
average, each score is multiplied by the decimal equivalent 
of its weight, and the weighted scores are added up. The 
only restriction on a weighted average is that the weights 
must sum to 1 (or 100%). You could type this in by hand, 
for example: =0.25*q3+0.25*r3+0.5*s3 but the problem 
with that is you would have to get into each cell to make 
the change if you need to alter the weights for a different semester or class.  
 
Excel has a function called sumproduct, which adds the products within a range of cells, so by 
using that function, we can avoid having to type in all that in the example above. In addition, 
because functions can refer to cell contents – and thereby change as the cell content changes – we 
use the cell references for our weights, and so if they change, our formula results will 
automatically changes. For example, if the weights change (so the final exam is now worth 40%, 
and the midterm and homework are now 30% 
each), as long as the cells themselves are 
referenced (rather than the specific numeric 
value), the formula will automatically update. 
 
If we add the weights above each column 
heading, insert the sumproduct function, 
choose the student’s scores (Array1) and then 
the weights (Array2), the formula will be 
correct for the first student. If we try to use 
the AutoFill command, however, as we 
discussed in the Using AutoFill for Formulas on 
page 4, both cell references will moved down 
– so the second student’s formula would be 
incorrect (as shown at lower right). 
 
We can either use the $ (dollar sign) to “lock 
in” the cell references for the weights, or we 
can define a named area referencing the cells with the 
weight information, and then use that name in the 
formula to reference those cells. 
 
Before we define a name, create a new column for the 
weighted averages for all of the students.  This way we 
can compare the weighted averages with the non-
weighted averages. 
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DEFINING A NAMED AREA 
1. Enter a set of weights for each score at the top or bottom of each grade column (e.g. .25, 

.25, .50).  Make sure the weighting adds up to 1.  
2. Select the cells containing the weights. 
3. In the Insert menu, Name, and then Define….  
4. In the Define Name

name in the Name: field – note, Excel 
 dialog box, type a 

may guess at a name if an adjacent cell 
seems to be the label. 

5. If you’ve already selected the cells (as 
we suggested in step 2), the Refers To: 
field will already have the correct cell 
information. 

6. Click OK to accept the name for these 
cells – in our example here, “Weights”. 

 

USING THE NAMED AREA IN A FORMULA 
In the Weighted Score column you created, click in the empty cell for the first student’s score. To 
insert the sumproduct function,  

1. Go to the Formulas Builder and type in sumproduct in the Search box. 
2. Select the cells with the first student’s scores for Array1. 
3. Type in the name Weights (or 

whatever you called it) in Array2. 
This field is not case-sensitive - you’ll 
know you have it correct with the 
contents of the cells displays next to 
the field, and the result will display in 
the lower right of the dialog box. 

4. Click OK to exit the dialog box.  
5. Use the fill handle to extend the 

formula to all students. 
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Quick Reference: 
1. Create columns for scale and grades 
2. Select the scale and letters and name 

them 
3.  Insert the vlookup function  

a.  Look_up value = first students score 
b.  Table_array = Scale 
c.  Col_index_num = 2  

4. Click OK and AutoFill formula 

SUBSTITUTING LETTER GRADES EXERCISE 
Rather than entering letter grades by hand, Excel can 
do it for you. This also allows you to try different 
grading curves with a minimum of effort. We will 
create a table that has the numeric value of the student 
scores and the corresponding letter grade, and then use 
the vlookup function (vertical lookup) to compare each 
student’s score to the table and return the proper letter 
grade. 

1. Create a column for the students called Grade 
(or whatever you want). 

2. Off to the side, add two other column headings for Scale and Letter Grade. This area is 
what we will compare to the student’s score. 

a. Under Scale, enter a straight 
scale by typing 0, 60, 70, 80, 90, 
down the column. For automatic 
grade assignment, you must start 
with the low score and increase 
as you go down.  

b. Under Letter Grade, enter ‘E’, ‘D’, ‘C’, ‘B’, ‘A’. Your scale can be as detailed as 
you’d like (meaning, you can use A, A-, B+, B, etc.), but you need to set that up 
before you name the area (as in steps 3-6 below). If you change your mind later, you 
will need to redefine the area. 

To use the same scale for all of the students, we will name that area, and then use the name in the 
formula (as we did with the weighted averages). Otherwise, if we copy the formula down (or use 
AutoFill), the references to the cells that contain the scores and grades would change, and the 
result would be incorrect.  

3. Select the cells containing the scale and the letter grades, but not the headings themselves 
(as shown in the picture above). 

4. In the Insert menu, Name, and then Define….  
5. In the Define Name
6. If you’ve already selected the cells, the Refers To: field will already have the correct cell 

information. Click OK to accept the name.  

 dialog box, type a name in the Name: field – for example, “scale.” 
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Now we’re ready to use that newly named area to assign grades. The vlookup function looks up a 
value in the first column of a table (where the values in the first column are increasing) and 
returns the value in any other column of the table. In our case, then, we will compare the student’s 
weighted score to the first column of the table (our scale) and return the value in the second 
column (the letter grade). Because we have defined this area with a name, if we change the scale to 
grade on a curve (so, to get a B you only need 75 instead of 80, for example), the letter grades will 
automatically adjust. 

7. Put your cursor in the Grade column for the first student then go to the Formula Builder 
and type vlookup in the Search box. Double-click on it when you see it. 

8. In the Formula Builder, 
a. Click in the Lookup_value field, and then click on the first student’s weighted score. 
b. In the Table_array field, type in what you called the scale and letter grades area – 

remember, you’ll know you’re correct if the scale and letter grades appear to the right 
of the field . 

c. In the Col_index_num field, put in the column number that has the result you would 
like to appear – in our case, it’s column 2 that has the letter grades we want to appear 
next to each student’s weighted score. The correct letter grade should appear to the 
right and below the fields in the dialog box. 

d. Note the range_lookup argument is not bold. That means it’s optional. 
e. Click OK, and the grade that corresponds with the student’s score should appear. 

9. Use the fill handle to fill the formula in to the rest of the students. Note that we don’t 
have to worry about the reference to our scale because we used a name.  

You can change the curve to something else (e.g. 55, 65, 75, 85) and see how that influences the 
grades.  
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COUNTIF EXERCISE 
COUNTIF is a useful function that will only count the data if the data meets certain criteria. As 
with any function, place your cursor in the cell where you would like the result to display. 

1. Go to the Formulas Builder and type in countif in the Search box. 
2. Once you see COUNTIF as an option in the Formula Builder, double-click it to activate 

the lower portion of the Formula Builder. 
3. Click in the Range field and then select the 

data you wish to count – in our example, 
the Panes and Formatting sheet, column L. 
Notice that items in the column will display 
to the right of the Range field. 

4. Click in the Criteria field and then click on 
the cell that contains the data you wish to 
count – in our example, cell A2. Again, the 
contents of that cell should display to the 
right of the Criteria field, and the result 
should display below. 

5. Press Return on the keyboard to accept the formula. 
Since we’ve referenced cells in both fields of the dialog box, you can use the AutoFill feature as 
we’ve discussed before. 
 

TRIM EXERCISE 
Sometimes your data has extra spaces at the beginning of the cell, so it won’t sort or filter 
properly.  You can use the TRIM function to get rid of them. 

1. Create a new column heading (for example, “Fixed”). 
2. Go to the Formula Builder, and type trim in the Search box. Double-

click on TRIM to activate the lower portion of the Formula Builder. 
3. In the Text field, click on the cell that you would like to change, 

then press Return on the keyboard to accept. 
4. Use the AutoFill feature to fill in this formula for the rest of the 

column. 
5. Select and copy the cells in the Fixed column, then in the first cell 

in the original column, right-click and choose Paste Special from 
the shortcut menu. 

6. Make sure the Values radio button is selected, and press OK. Delete 
the fixed column. 
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FORMATTING 

CELLS, COLUMNS AND ROWS 
You can format the font, number, alignment, border, pattern, and 
protection of your cells, rows, and columns by going to the Format 
menu and selecting Cells… or by using the Formatting Palette. 

 
Font Tab/Section: change the font, size and color text. 
Number Tab/Section: specify the format of the cell (such as currency, 
time, etc.) 
Alignment Tab/Section: set the alignment and orientation of the text. 
You can also choose to wrap text in a cell or merge cells. 
Border Tab/Section: change the color (fill color) and border of the cell. 

SETTING UP THE PAGE 
Go to the File menu and choose Page Setup… or go to the Page Setup 
section of the Formatting Palette to change the margins, page 
orientation, show/print gridlines, and to adjust the print size. 
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SORTING DATA 
For a quick sort, click the Sort icons in the Standard toolbar (see right). For a more 
complex sort, go to the Data menu and choose Sort…. 

If your columns have a header row (meaning, the label for 
what’s in the column is in the top row), then you can 
choose the column in the pulldown menus. Otherwise, the 
menus say Column A, Column B, etc. 

You can sort by up to three factors;  if you only need one, 
just leave the other two blank. Note that for the first sort 
order, you can click the Option button to bring up special 
options.  

Click OK when you are done. 

FILTERING DATA 
In addition to sorting, you may find that adding a filter allows you to better 
analyze your data. When data is filtered, only rows that meet the filter criteria will 
display, and other rows will be hidden. With data filtered, you can then copy, 
format, print, etc., your data, without having to sort or move it first. To use a 
filter, go to the Data menu, then Filter, then AutoFilter…. 

The column headings all now have a double arrow next to the heading name.  
Click on the arrow next to the heading by which you want to filter, and you will 
see a list of all the unique values in that column – choose the one you want. 

Now the double arrow for the filtered column is blue; click on the arrow next to 
another heading to further filter the data. You’ll also notice that the rows that 
don’t meet the criteria are hidden, as indicated by the 
blue numbers for the rows. 

In the example at right, first the data was filtered by 
the day Tuesday, and now will be filtered by the level 
Intermediate, so the only ones that will display are 
Intermediate ones that occur on Tuesday. 
 
To clear the filter, choose (Show All) from the double 
arrow in the column you want display again, or go to 
the Data menu, then Filter and Show All. 
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ADVANCED FILTER 
To employ an advanced filter, go to the Data menu, Filter, 
and then Advanced; the Advanced Filter dialog box will 
display. This dialog box allows you to set a particular criteria, 
copy results to another location (the other location must be in 
the same sheet), and capture unique values. In the example at 
right, unique values for the Sponsor column are now displayed 
to be copied to a new location. 

 

 

ADDING A CHART 
To add a chart, select the data you wish to appear in the chart. If the data is noncontiguous, select 
one set, then hold down the Command/Apple key on the keyboard to select the second set. 
Click on the Charts tab in the Elements 
Gallery and click on the type of chart you 
want. 
 
By default, the chart will just appear on the 
spreadsheet, and now you can move or modify 
it  as described below.  
 
To change the chart type (from Column to 
Area, for example), click once on the chart 
then click on a different icon in the Charts tab 
of the Elements Gallery. 
 

MOVING THE CHART 
You can move the chart around on the spreadsheet by 
clicking on it and then dragging it with a mouse. To move 
it to its own worksheet (so you can see it more clearly, 
print it easily, etc.), use the menu that appears only when 
the chart is selected – the Chart menu – and select Move 
Chart…. 
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MODIFYING A CHART 
Whether the chart is an object on the worksheet with the data or on it’s own sheet, there are many 
ways to modify the way it looks and it’s location. A few ways are described below, but explore to 
find more! In all cases, you have to select the chart first. 
Add a title, move the legend and so on 
in the Chart Options section. 
 
Edit the data by just changing it directly 
in the datasheet, or by clicking on the 
Edit… button in the Chart Data section. 
Clicking this button will jump you to the 
data in the chart.  
 
Change the style of the chart in the 
Chart Style or Quick Styles and Effects 
sections of the Formatting Palette. 
 
Change the color, etc. of the data 
series, by selecting it and changing it in 
the Colors, Weights, and Fills section of 
the Formatting Palette or by double-
click on it to open the Format Data 
Series dialog box (shown below). 
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WORKING WITH PIVOT TABLES 
A pivot table is a way to summarize and view large amounts of raw data in an easy to read format. 
The pivot table doesn’t change your raw data, but rather creates a new view of it. While there are 
many more things you can do with pivot tables than the below,  let’s look at an example. 

SELECTING THE DATA 
1. Put your cursor anywhere 

in your data set (you 
don’t have to select it all), 
then go to the Data 
menu and choose Pivot 
Table Report…. 

2. If you choose Microsoft 
Excel list or database in the PivotTable Wizard 

should be included; if it’s wrong, select the correct data in the Range: 
and click Next, Excel will guess at which data 

field of the PivotTable Wizard – Step 2 of 3 dialog box. 
3. In Step 3

common to put the pivot table in a new sheet, but you could change 
, choose where you want the pivot table to appear - it’s most 

the radio button to Existing sheet if you want. You could edit the layout 
at this point, but we’ll do that in the next step. Click Finish. 

CREATING THE REPORT 
When you click Finish, you will be brought to a new 
sheet, and the PivotTable toolbar will display. The 
PivotTable toolbar lists your column headings, while 
the sheet itself prompts you create your pivot table 
by dragging fields into place.  

1. To create the pivot table, drag the fields 
from the PivotTable
Row Fields Here area – items in that column will display in the 

 toolbar into the Drop 

sheet area. 
2. Depending on what you are trying to do, drag other fields into the 

Drop Data Items Here area.  
3. In the PivotTable

and choose Field Settings to change the value (for example, from 
 toolbar, click on the PivotTable pulldown menu 

count to sum) . 
If you change your data on the source spreadsheet, be sure to click on the 
Refresh icon in the PivotTable toolbar, or from the PivotTable pulldown 
menu. 
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